読者です 読者をやめる 読者になる 読者になる

妹でもわかるUnrealEngine4

毎日更新? 妹に説明するために書いてるけど、たまにわかってない場合もあるUnrealEngine4を中心としたゲーム制作の話。略すとイモリアル

毎日更新? 妹に説明するために書いてるけど、たまにわかってない場合もあるUnrealEngine4を中心としたゲーム制作の話。略すとイモリアル

GooglePlayでの公開には、UE4.13.2以降のバージョンが必須に

UE4.13 アップデート情報 仕様・不具合 スマートフォン対応

libpng v1.0.66、v.1.2.56、v.1.4.19、v1.5.26 以降に移行の仕方について - UE4 AnswerHub

「先日の4.13.2アップデートだけど、どうもあのバージョンを入れてないと、GooglePlayっていう、Androidスマートフォン用の公式サイトに登録出来ないようになったみたい」

妹「たしかセキュリティがどうのこうのって話だったっけ?」

「そうそう。だから古いUE4で作ったゲームは、いま公開中のはそのまま遊べるけど、バージョンアップする時にそれだと怒られるみたい」

妹「UE4のバージョンを上げられる場合はいいけど、プラグインとかの事情で出来ない時はどうするんだろ?」

「4.12以前の分はアップデートされないだろうと思う。具体的にはUE4に含まれてるlibpngというプログラムのバージョンが古いとダメだから、この部分だけ自分で差し替えて、エンジンを丸ごとコンパイルしなおすっていう方法はある。これはこれで大変だし、4.13に移行出来ればそれが一番だと思うけど」

妹「4.14は?」

「アップデート情報には書いてなかったからわからないけど、少なくとも正式版が出た後は大丈夫なはず。今のでもいけるかもしれないけど、Preview版は本公開用のプロジェクトには使わない前提だから」